SPiDiGO - Login problems and connectivity problems

 
7 Reviews
User
  Sankalp Mehta
I am facing too much problems using my internet from 12-1-2010.

1. It takes too much time to get login after entering the username and password and many times it doesn't even accept the login.

2. Internet speed has become very slow due to which i am facing problems in downloading.

3. My account automatically gets logged out within an hour or so, and i have to login again and again..

I have complained more than 3 times but till know i don't have any response from the company
and also the call center number is not contactable. It's always showing busy tone.

I need a quick response from the company on this issue.
[Updated by govindgoswami May 12, 2014]

Complaint comments 6 Comments     Updated:
Resolve this Complaint  

Comments

 
when i am started internet page, client page(my account) is not come. Direct home page is come.
so how can i get my account (client) page when start the internet.
A
User
bjagad  
 
i agree to the complaint as i had the same problem but the solution is that u go to the my account page get logged in and go to the client link and download the software for windows and install it. after that restarting the machine give the server address in the required field (172.16.0.1 for ahmedabad ) and click check. thats it now u will not logged out automatically.

try this and reply.
N
User
rohitw1  
 
spidigo login home page does not show
D Dec 14, 2012 by
User
HARSHAD49  
 
Spidigo helpdesk has closed my complaint without solving on 14th December 2012. This is ridicules. Even no phone call is made after registering complaint. I have complained more than 5 times in last 15 days. If this is the service they provide, I think we should complaint to the Consumer Redressing Forum against the company.
N Nov 20, 2014 by
User
Faiyazuddin Shaikh  
 
spidigo is bakvas internet brodband is very slow internet 1 mbps spped =0.56 and uplod spped 0.03mbps please help me
N Jan 11, 2015 by
User
jayshah086  
 
Hello... I am also a spidigo user, and I have also faced same problems. Here are few suggestions.

1) Call frequently to spidigo @ 079-66199999
2) If they don't answer properly, be aggrasive on them. Directly go to their office and have guts to fight with them. Going to office worked for me. Since 6 months I have not encountered any problem.
3) Now something technical... The device installed on terrace may not be in right direction, like it was installed. Try moving it and check whether you get full network strenght or not. You can observe this by the small led lights behind the bullet or TP-Link device, mostly in green color.
4) regarding to the busy tone on complain number, yes it is true. But by trying again and again it will connect to the customer care. Once you talk to them, make sure you ask for trouble ticket (complain number).

Post your Comment

    I want to submit Complaint Positive Review Neutral Comment
    Your Rating (1 star is bad, 5 stars is good) No Rating
    code