Show menu
Close
FAQ FAQ Categories Categories Sign in Sign in
Close
ADVERTISEMENT

[Resolved]  Maruthi Swif Vdi — Immobiliser indication and starting trouble

I own a Swift vdi diesel car purchased in 2007 June from Hercules motors Trivandrum. Regn No of vehicle is KL01 AQ 8771. Off late -after the 40k km service, i am experiencing typical problem with the car which at times is creating embarrassing situations.
The first time i experinced the problem was 1 month ago and the incident wals like this..." Morning whehn I inserted the key and switched to ON position all the indications in the odometer panel was on. But the immobiliser indication light which was supposed to turn off in 3 seconds did not turn off and when I cranked the engine, car started and stopped immediately with the immobiliser indication blinking. I switched off and then again switched on.This time also the immobiliser indication didnt go off. But I was able to start the car with immobiliser and "moisture in Diesel" indications turned on always. I immediately took the car to my service centre(Hercules Motors,trivandrum) and they checked the car for 1 hour and said no major complaints can be identified. After that I was able to drive the car but with the hitch of intial starting troubles as mentioned earlier. But y day night I drove the car for nearly 40 kms and stopped the car.Then while trying to start the car again after 5 minutes to my dissapointment it didint start. I tried several times but in vain. I called the MOS from hercules and they responded very well by landing in 15mts time.They cheked the vehicle and couldnt identify the problem. Then they helped start the car by cranking the car with release of clutch by pushing thru the road.
I gave the car to service centre today. And I am confident about only few mechanics (Mr Binu) in that dealership. Now they say that itz Battery problem and needs to be replaced. But there are no indications of Battery failure and lights and horn are working perfectly.Earlier they told this might be sensor failure
Can somebody throw light on the exact problem? Hope this letter reaches Maruti and they come with a solution ASAP. My car is in extended warranty period.

Regards
Shibu Salam
[protected]
Trivandrum
Was this information helpful?
Yes (0)
Aug 14, 2020
Complaint marked as Resolved 
Complaint comments  1 CommentShareTweet

Comments

I have a similar problem. They (Sai Service, Pune) told me that either the immobilizer or the Battery needs replacement. They have asked me to use the other spare key for the time being to check if it is a immobilizer problem.. Wierd. But, I am doing it. I have noticed that it is taking more time for the engine to turn on during startup. So I guess, they are right about the battery issue. I've driven the car for 56000 kms and it is 2 years old. My conclusion is that I am waiting for the SVS light to blink again, so that I come to know whether the key was faulty or the battery needs replacement. They told me that its a remote possibility that the immobilizer (iCATS) system has gone faulty. So, it all comes down to one solution - Change the Battery.

Post your Comment

    I want to submit Complaint Positive Review Neutral Comment
    code

    Contact Information

    India

    Add Company Information

    ADVERTISEMENT