VAS Data Services Pvt. Ltd. / Growthways Trading Pvt. Ltd. Support

111
7 440 Reputation points
1393
Comments
0
Complaints
   
 

Upload Photo

Choose a picture
 

 
   

VAS Data Services Pvt. Ltd. / Growthways Trading Pvt. Ltd. Support Profile

  • India

Activity statistics

Posting summary

493 days ago
Yepme.com - non delivery of product
493 days ago
Yepme.com - not delivering the product
493 days ago
Yepme.com - poor response
493 days ago
Yepme.com - product not delivered nor there is no tracking updates
493 days ago
Yepme - order issue
493 days ago
Yepme - order issue
493 days ago
Yepme.com - order booked but not delivered yet
493 days ago
Yepme.com - shoe / didn't get any information and took the payment also
493 days ago
Yepme.com - shoes sports not received
493 days ago
Yepme.com - late delivery
493 days ago
Yepme.com - order id not generated
493 days ago
Yepme.com - I didn't get my order.
493 days ago
Yepme.com - cancelled order but refund not done
493 days ago
Yepme.com - order - 33788247 cancelled but refund not done
493 days ago
Yepme.com - cheating consumer in refunding amount
493 days ago
Yepme.com - order id not generate
493 days ago
Yepme.com - order no 34061395 yet not delivered status is showing pending review
493 days ago
Yepme.com - refund
493 days ago
Yepme.com - wrist watch
493 days ago
Yepme.com - refund process
493 days ago
Yepme.com - order cancelled but money not refunded
508 days ago
Yepme.com - delay in dispatching the orders
508 days ago
Yepme.com - yepme product not delivered
510 days ago
Yepme.com - already paid for the product but still not been delivered yet
515 days ago
Yepme.com - product not yet delivered

Recently Discussed

(14 minutes ago)
Flex Enterprises
fraud data entry job
(1 hours 45 minutes ago)
Hdfc Bank
amount from my debit card, but i have not doing any order or not received any order id
(5 hours 17 minutes ago)
Gold Souk
property scam in Gurgaon Sohna road
(5 hours 44 minutes ago)
Jiten Bhatt Or Jatin Arora
Fake
(6 hours 9 minutes ago)
Lenovo
lenovo k8 note motherboard issue